There are several routines and global variables defined in plot.lisp which
are user-accessible (they are $-symbols) but which appear to be strictly
internal to the plotting package, and are not documented anywhere.
Some of the names make them sound as though they could be general-purpose
routines (doesn't rotate_list sound as though it rotates a list?), but in
fact they are very specific to the internal needs of the plotting package.
pstream (variable)
rot (variable)
rotation1
rotate_list
rotate_points
get_range
polar_to_xy
concat_polygons
copy_pts
view_zic
isend
zero_fun
I recommend that we rename these to non-$ symbols so they aren't visible to
users, who might redefine them accidentally.
Along the same lines, I noticed that the routine <join> is defined in
plot.lisp and not used anywhere.* This one is documented, but a) it should
be moved to be with other list functions b) it should get a better name
(maybe "intersperse") and c) it should be more general -- right now, it can
only intersperse two lists, not N. Others' thoughts?
-s
* Actually it was Sheldon who pointed it out to me... and led me to notice
the other strange routines.