Thoughts on changing the testsuite



One thing that annoys me with the test suite is the fact that some
tests are known to fail, but they are not explicitly marked as such
except as a test number in the file tests/testsuite.lisp.

When a new test is added or an old test removed, the test number in
testsuite.lisp has to be updated.  This is annoying.

I was thinking if we could make this more explicit.  Suppose each test
were changed to be

deftest(name, fail, test, expected_result);

The NAME could be just some arbitrary symbol used to identify the test
in some way.  It could be as simple as "rtest1_1".  Better names would
be better, but not required.  The parameter FAIL would be set to true,
if the test is known to fail.  TEST is the current test, and
EXPECTED_RESULT is the expected result.

Not sure exactly how to implement this idea, but I think it would make
the testsuite nicer.

This change would, of course, be a lot of work because every test file
would need to be changed, and we might not want to do that.

Ray