run_testsuite interface change?



>>>>> "Robert" == Robert Dodier <robert.dodier at gmail.com> writes:

    Robert> On 1/19/09, Raymond Toy <raymond.toy at ericsson.com> wrote:
    >> Something like
    >> 
    >> run_testsuite(display=<t/f>, known_bugs=<t/f>, tests=<list of tests>)

    Robert> OK by me. Instead of display and known_bugs, I am inclined to name
    Robert> the parameters display_all and display_known_bugs.

    Robert> At present, the elements of the list of tests must be strings;
    Robert> I think symbols should be allowed also.
    Robert> i.e. [rtest10, rtest15] as well as ["rtest10", "rtest15"].

Done, with documentation updated.

run_testsuite(display_all = t);

or

run_testsuite(display_known_bugs=t, tests=["rtest5"]);

Note however, that in this case problem 48 is a known test failure.
BUT, the result matches the expected result, so problem 48 doesn't
actually fail anymore.

I think this is bad.  We should do something so that if a test is
expected to fail but doesn't, we should complain about that.

Ray