pdf_continuous_uniform



> 
> pdf_continuous_uniform(x,a,b):=if maybe(b < a) = true then
> error("Illegal argument")
>                         elseif maybe(a < b) = true
>                         then (if maybe(a < x and x < b) = true then 1/(b-a)
>                                   elseif maybe(x <= a or b <= x) = true then 0
>                                   else funmake('pdf_continuous_uniform,[x,a,b]))
>                         else funmake('pdf_continuous_uniform,[x,a,b])$
> 
> If I'm not mistaken, the definition above has the same behavior as the
> existing one.
> I claim that calling "maybe" is clearer than the existing constructs:

Looks easier to read. I'll take a look at this in the (I hope) near future.

I should have remember function 'maybe' from the docs translation. 
Thanks for the hint.



-- 
Mario Rodriguez Riotorto
http://www.telefonica.net/web2/biomates