>I'm a bit confused. Why are you trying to define a "diff_pwdelta"
>function at all? Can't you just use the noun form 'diff(pwdelta...) ?
>Rupert
Yes, that is sufficient and gives correct results but it is hard to prevent
endless loops or stack overflow because Maxima tries to evaluate diff() if
the answer is in noun form when the pw.mac package is loaded. There are
historical reasons for this too, it is the way I choose to do it when pw.mac
was just beginning. I think I would have to rewrite a lot of code to fix
it. I may do that anyway. I am thinking seriously about redefining
pwdelta() to be a one or two argument function and getting rid of
diff_pwdelta(). The time involved may be too much.
diff_pwdelta(n,x) = pwdelta(n,x)
and pwdelta(x) would be unchanged.
Rich